aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-mongo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-19 22:51:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-24 16:43:22 -0300
commit46ecca97e9e72e1a0228912666c9278226be53b9 (patch)
tree6244a9a8ad09ad7b51658f3e9ca0bcbd36873c41 /testing/py3-mongo
parent835349acfdb4950ceb46d81354b952a4934a294a (diff)
downloadaports-46ecca97e9e72e1a0228912666c9278226be53b9.tar.bz2
aports-46ecca97e9e72e1a0228912666c9278226be53b9.tar.xz
testing/py3-mongo: drop py2
Diffstat (limited to 'testing/py3-mongo')
-rw-r--r--testing/py3-mongo/APKBUILD43
1 files changed, 9 insertions, 34 deletions
diff --git a/testing/py3-mongo/APKBUILD b/testing/py3-mongo/APKBUILD
index d85f4ce849..e2d5cc787d 100644
--- a/testing/py3-mongo/APKBUILD
+++ b/testing/py3-mongo/APKBUILD
@@ -1,55 +1,30 @@
# Contributor: Danilo Falcão <danilo@falcao.org>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-mongo
+pkgname=py3-mongo
_pkgname=pymongo
pkgver=3.7.2
-pkgrel=0
-pkgdesc="A Python driver for MongoDB"
+pkgrel=1
+pkgdesc="Python3 driver for MongoDB"
url="https://github.com/mongodb/mongo-python-driver"
arch="all"
license="Apache-2.0"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+makedepends="python3-dev py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-mongo" # Backwards compatibility
+provides="py-mongo=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d pymongo-3.7.2.tar.gz"