aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-mongo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-19 22:50:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-24 16:43:22 -0300
commit835349acfdb4950ceb46d81354b952a4934a294a (patch)
tree5615e6c36e717b5931f9a6bb9b9ea99e2ca05dab /testing/py3-mongo
parentfacbf31f931fb423153e744ca5c198e77921e410 (diff)
downloadaports-835349acfdb4950ceb46d81354b952a4934a294a.tar.bz2
aports-835349acfdb4950ceb46d81354b952a4934a294a.tar.xz
testing/py3-mongo: rename from py-mongo
Diffstat (limited to 'testing/py3-mongo')
-rw-r--r--testing/py3-mongo/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-mongo/APKBUILD b/testing/py3-mongo/APKBUILD
new file mode 100644
index 0000000000..d85f4ce849
--- /dev/null
+++ b/testing/py3-mongo/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Danilo Falcão <danilo@falcao.org>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-mongo
+_pkgname=pymongo
+pkgver=3.7.2
+pkgrel=0
+pkgdesc="A Python driver for MongoDB"
+url="https://github.com/mongodb/mongo-python-driver"
+arch="all"
+license="Apache-2.0"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d pymongo-3.7.2.tar.gz"