aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-mopidy-subidy
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-04-18 10:53:39 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-04-18 20:00:44 +0000
commit06f07a6c1a64e32f4c1637aba8f30c54d111fa52 (patch)
tree135faab35a3972e31e99fbf7b6663ae4bcb54f78 /testing/py3-mopidy-subidy
parent75b77b2b09367e66bdb8c4447ca29fdd347a1c61 (diff)
downloadaports-06f07a6c1a64e32f4c1637aba8f30c54d111fa52.tar.bz2
aports-06f07a6c1a64e32f4c1637aba8f30c54d111fa52.tar.xz
testing/py3-mopidy-subidy: new aport
https://github.com/Prior99/mopidy-subidy Mopidy extension for playing music from Subsonic servers testing/
Diffstat (limited to 'testing/py3-mopidy-subidy')
-rw-r--r--testing/py3-mopidy-subidy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-mopidy-subidy/APKBUILD b/testing/py3-mopidy-subidy/APKBUILD
new file mode 100644
index 0000000000..d668efc6fc
--- /dev/null
+++ b/testing/py3-mopidy-subidy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=py3-mopidy-subidy
+_pyname=Mopidy-Subidy
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Mopidy extension for playing music from Subsonic servers"
+url="https://github.com/Prior99/mopidy-subidy"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 mopidy py3-pykka py3-pysonic"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eb0068646c8865d7be62f0c4075cc97dedd8dd52d96f5fa55f9626ca90e00b89211fac48d470f615066584c19dcbe8f4ef18a9dbfe3e2f3a57c96349272cfb36 Mopidy-Subidy-1.0.0.tar.gz"