aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-netdisco
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-02 21:46:17 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-04 20:51:25 +0000
commitcb1bb3fa357a5613c11dadbb7f7fda23f8ca9294 (patch)
tree7c105ce357589913d9fafbd6acfed280a533fd32 /testing/py3-netdisco
parent381c5afc56acd6da2dc0c456791e181d5f2270bc (diff)
downloadaports-cb1bb3fa357a5613c11dadbb7f7fda23f8ca9294.tar.bz2
aports-cb1bb3fa357a5613c11dadbb7f7fda23f8ca9294.tar.xz
testing/py3-netdisco: modernize
- Fix license - Lighten makedepends - Remove superflous depends - Enable tests
Diffstat (limited to 'testing/py3-netdisco')
-rw-r--r--testing/py3-netdisco/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/py3-netdisco/APKBUILD b/testing/py3-netdisco/APKBUILD
index 60f0db0f9d..f4b1e526b4 100644
--- a/testing/py3-netdisco/APKBUILD
+++ b/testing/py3-netdisco/APKBUILD
@@ -1,31 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-netdisco
_pkgname=netdisco
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to scan local network for services and devices"
url="https://github.com/home-assistant/netdisco/"
arch="noarch"
-license="Apache-2"
-# Tests require netlink support which is no present in AL
-options="!check"
-depends="py3-zeroconf py3-requests py3-netifaces"
-makedepends="python3-dev py3-setuptools"
+license="Apache-2.0"
+depends="py3-zeroconf py3-requests"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- python3 setup.py test
+ python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}