aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-nikola
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-12 12:53:59 +0300
committerprspkt <prspkt@protonmail.com>2019-06-12 12:54:13 +0300
commit4b6a71efc3bd8a97017ae4d1bdd9032db48f46d6 (patch)
treec2a2ce6196c09aeaee48bada8b1a3189d515d67f /testing/py3-nikola
parent16a4bf59a1b088f852dab20a6a90e47889f8826b (diff)
downloadaports-4b6a71efc3bd8a97017ae4d1bdd9032db48f46d6.tar.bz2
aports-4b6a71efc3bd8a97017ae4d1bdd9032db48f46d6.tar.xz
testing/py3-nikola: make backwards compatible
Diffstat (limited to 'testing/py3-nikola')
-rw-r--r--testing/py3-nikola/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/py3-nikola/APKBUILD b/testing/py3-nikola/APKBUILD
index a6f9b8cd9b..51d049dd39 100644
--- a/testing/py3-nikola/APKBUILD
+++ b/testing/py3-nikola/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-nikola
_pkgname=Nikola
pkgver=8.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A modular, fast, simple, static python website generator"
url="https://getnikola.com"
arch="noarch !s390x" # limited by py3-piexif
@@ -17,6 +17,9 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
fix-requirements.patch"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-nikola" # Backwards compatibility
+provides="py-nikola=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
python3 setup.py build
}