aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-notifymail
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 04:54:47 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 19:32:16 +0200
commitcb2de737bda7449721327c22987086a88ac5ae83 (patch)
treecc04542451c6c1dc9a09a163592043329fa786bf /testing/py3-notifymail
parentd10d36564ca463e34ea1b0573cf4cfc6100e881a (diff)
downloadaports-cb2de737bda7449721327c22987086a88ac5ae83.tar.bz2
aports-cb2de737bda7449721327c22987086a88ac5ae83.tar.xz
testing/py3-notifymail: modernize
Diffstat (limited to 'testing/py3-notifymail')
-rw-r--r--testing/py3-notifymail/APKBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/testing/py3-notifymail/APKBUILD b/testing/py3-notifymail/APKBUILD
index b924e370fb..c3894d1153 100644
--- a/testing/py3-notifymail/APKBUILD
+++ b/testing/py3-notifymail/APKBUILD
@@ -11,31 +11,18 @@ license="MIT"
replaces="py-notifymail" # for backwards compatibility
provides="py-notifymail=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="f06bf000c0855c852bc4fccfb5da5c625bbabe334640dc6557e6518a5657b61ec2fd546cb92ef63cb66b64c6ce469cfb94da21f844e1c6934cc1339a08fe3f1a notifymail-1.1.tar.gz"