aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-openapi-codec/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-14 04:45:13 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-14 08:05:00 +0000
commitd5e1d60c43cb031602c3ec0da35ab2f100115672 (patch)
treea806b07bc45cc3c14bf53d7bae447c69e382aa64 /testing/py3-openapi-codec/APKBUILD
parentb7fbb3f41e08b64b33b823a16f064dbc3233959a (diff)
downloadaports-d5e1d60c43cb031602c3ec0da35ab2f100115672.tar.bz2
aports-d5e1d60c43cb031602c3ec0da35ab2f100115672.tar.xz
testing/py3-openapi-codec: rename from py-openapi-codec
Diffstat (limited to 'testing/py3-openapi-codec/APKBUILD')
-rw-r--r--testing/py3-openapi-codec/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-openapi-codec/APKBUILD b/testing/py3-openapi-codec/APKBUILD
new file mode 100644
index 0000000000..f268fe7fe5
--- /dev/null
+++ b/testing/py3-openapi-codec/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-openapi-codec
+pkgver=1.3.2
+pkgrel=2
+pkgdesc="OpenAPI codec for Core API"
+url="https://github.com/core-api/python-openapi-codec"
+arch="noarch"
+license="BSD-2-Clause"
+depends="py-core-api"
+makedepends="py3-setuptools py2-setuptools"
+checkdepends="py-coverage pytest py-jinja2 py-pycodestyle py-pyflakes"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-openapi-codec/archive/$pkgver.tar.gz
+ disable-flake8-tests-that-requires-pyflake15.patch
+ "
+builddir="$srcdir"/python-openapi-codec-$pkgver
+
+build() {
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ python2 runtests
+ python3 runtests
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="566c82643bd6ad3e9bc444ceb9a518cb8bdddc9239f43e8bcce69d3b425a9d62b5d56d56cbe685fb0d054c1c3e33a19b010d5f8b4469d1c98fd092742b17bb22 py-openapi-codec-1.3.2.tar.gz
+6807f1d48f17bcec58642037e262246b818fb0e5d522606c46fbe343fd2c7d5388a40d29e6d361ad34d92611a1eb24e29cc78377472bd608503a71c8e8017363 disable-flake8-tests-that-requires-pyflake15.patch"