aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-orderedmultidict
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-01 01:00:46 +0300
committerprspkt <prspkt@protonmail.com>2019-06-01 01:02:16 +0300
commita932eeb833e670626d2dff2a00dfc929a8b2d901 (patch)
tree03ff5aa55772b7c8974750de64d8abccc70ec066 /testing/py3-orderedmultidict
parent2fc33d732f8bde9586d9151be783bd91465846de (diff)
downloadaports-a932eeb833e670626d2dff2a00dfc929a8b2d901.tar.bz2
aports-a932eeb833e670626d2dff2a00dfc929a8b2d901.tar.xz
testing/py3-orderedmultidict: new aport
Diffstat (limited to 'testing/py3-orderedmultidict')
-rw-r--r--testing/py3-orderedmultidict/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-orderedmultidict/APKBUILD b/testing/py3-orderedmultidict/APKBUILD
new file mode 100644
index 0000000000..3c46d8f70f
--- /dev/null
+++ b/testing/py3-orderedmultidict/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-orderedmultidict
+_pkgname=orderedmultidict
+pkgver=1.0
+pkgrel=0
+pkgdesc="Ordered Multivalue Dictionary"
+url="https://github.com/gruns/orderedmultidict"
+arch="noarch"
+license="Unlicense"
+depends="py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-pycodestyle"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7f731bde1f9cdd3e0490d3f590f2bfefa21935155d309d7460e45e11a640272de15a192200cb5110cf45876b7d6f0b6c7eac635fd122f6225b25aca90a4d6d36 orderedmultidict-1.0.tar.gz"