aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-passlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 05:03:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-03 08:06:02 -0300
commit8b216191737c140f4d84e88722269d3796832317 (patch)
tree49ca7f9a6ec210728467c5cc3ef8429669a0b7c3 /testing/py3-passlib
parent63ffc3781574a5cf58dba670521025ddebafc70a (diff)
downloadaports-8b216191737c140f4d84e88722269d3796832317.tar.bz2
aports-8b216191737c140f4d84e88722269d3796832317.tar.xz
testing/py3-passlib: rename from py-passlib
Diffstat (limited to 'testing/py3-passlib')
-rw-r--r--testing/py3-passlib/APKBUILD54
-rw-r--r--testing/py3-passlib/skip-bsdi_crypt-test.patch12
2 files changed, 66 insertions, 0 deletions
diff --git a/testing/py3-passlib/APKBUILD b/testing/py3-passlib/APKBUILD
new file mode 100644
index 0000000000..3e946ab8cd
--- /dev/null
+++ b/testing/py3-passlib/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor:
+# Maintainer:
+pkgname=py-passlib
+_pkgname=passlib
+pkgver=1.7.1
+pkgrel=2
+pkgdesc="A python hashing library for over 30 schemes"
+url="https://pypi.python.org/pypi/passlib"
+arch="noarch"
+license="BSD"
+checkdepends="py-nose"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ skip-bsdi_crypt-test.patch
+ "
+builddir="$srcdir"/passlib-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ nosetests --tests passlib.tests
+}
+
+sha512sums="3d5f069cd4e44e5e87cdabc46845acbdd6c1eeedb7ce1f611aebee87b0f7af19009b6a47a10ec555fd84260b9f5c933c6429e325d30326de3869f05031674168 passlib-1.7.1.tar.gz
+cdf085a94be88140dff421128bbeb9f4c05d13ae8c14ad80e7ab6d9edf2be19b0ad010eb18a5eccd3eefa679c4f634c6f98753571df72a1fc387343331fa8bae skip-bsdi_crypt-test.patch"
diff --git a/testing/py3-passlib/skip-bsdi_crypt-test.patch b/testing/py3-passlib/skip-bsdi_crypt-test.patch
new file mode 100644
index 0000000000..094ccd1412
--- /dev/null
+++ b/testing/py3-passlib/skip-bsdi_crypt-test.patch
@@ -0,0 +1,12 @@
+--- passlib-1.7.1/passlib/tests/utils.py
++++ passlib-1.7.1/passlib/tests/utils.py.new
+@@ -3171,8 +3171,7 @@
+ self.fail("expected %r platform would have native support "
+ "for %r" % (platform, self.handler.name))
+ else:
+- self.fail("did not expect %r platform would have native support "
+- "for %r" % (platform, self.handler.name))
++ raise self.skipTest("varied support on %r platform" % platform)
+
+ #===================================================================
+ # fuzzy verified support -- add new verified that uses os crypt()