aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pastel/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 02:22:40 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commit1a50dd67e74bda933b3926d6e890e3c639675d41 (patch)
tree4bdf5ef6f86e5316163433b146db4af9bdb5b57f /testing/py3-pastel/APKBUILD
parent626c2d3467df8fd905a3c1381d1bb6037e135169 (diff)
downloadaports-1a50dd67e74bda933b3926d6e890e3c639675d41.tar.bz2
aports-1a50dd67e74bda933b3926d6e890e3c639675d41.tar.xz
testing/py3-pastel: new aport
Python3 library to bring colors to your terminal url="https://github.com/sdispater/pastel Closes GH-8381
Diffstat (limited to 'testing/py3-pastel/APKBUILD')
-rw-r--r--testing/py3-pastel/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-pastel/APKBUILD b/testing/py3-pastel/APKBUILD
new file mode 100644
index 0000000000..a51f0be64b
--- /dev/null
+++ b/testing/py3-pastel/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pastel
+_realname=pastel
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Python3 library to bring colors to your terminal"
+options="!check" # No testsuite on tarball with setup.py
+url="https://github.com/sdispater/pastel"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/${_realname:0:1}/${_realname}/${_realname}-${pkgver}.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="05f40d56fed85e0dacd6dbec7f77a8b00f83e5f369f13acf9af74939e7c7472068a41a8b943d80dc4b312b3b0974d4b671ff5b4e4805e4d121336ca42905744d py3-pastel-0.1.0.tar.gz"