aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pdal
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:28:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 18:44:41 -0300
commite084f086d961ccd4f239d298f399e83b22f96e0c (patch)
treed77c1905ec2f241308a7110318cdf4dc35f12b6a /testing/py3-pdal
parent580c4c59398dedc98ebdccb1054e6c9f63dd1dbd (diff)
downloadaports-e084f086d961ccd4f239d298f399e83b22f96e0c.tar.bz2
aports-e084f086d961ccd4f239d298f399e83b22f96e0c.tar.xz
testing/py3-pdal: rename from py-pdal
Diffstat (limited to 'testing/py3-pdal')
-rw-r--r--testing/py3-pdal/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py3-pdal/APKBUILD b/testing/py3-pdal/APKBUILD
new file mode 100644
index 0000000000..6508a1424c
--- /dev/null
+++ b/testing/py3-pdal/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
+# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
+pkgname=py-pdal
+pkgver=2.1.8
+pkgrel=0
+pkgdesc="PDAL Python bindings"
+url="https://github.com/pdal/python"
+arch="x86_64"
+license="BSD"
+makedepends="cython python2-dev py-setuptools py-packaging pdal-dev>=1.7.2-r1 pdal>=1.7.2-r1 py-numpy-dev libxml2-dev"
+install=""
+subpackages="py2-${pkgname#py-}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PDAL/python/archive/$pkgver.tar.gz"
+builddir="$srcdir/python-$pkgver"
+
+build() {
+ python2 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//^py-/py2-}"
+ _py python2
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="63943f376083b66b531c7b85722e7878383cba0a0d35c751c6127ed4ccddfa4b8bf52ff00481971bb5af05d7b0bc7531b67571db3d147b5c86ecfb809d718954 py-pdal-2.1.8.tar.gz"