aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pdfkit/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 21:15:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 00:19:19 -0300
commit5b82ec46001681080d28e51dd2bcfc5f300343b5 (patch)
tree2a3431d17aedf2fa2152904e7c9c7d35d9fd3051 /testing/py3-pdfkit/APKBUILD
parentb6bea3a261a4d4038b623e93ca411a60bd89aa64 (diff)
downloadaports-5b82ec46001681080d28e51dd2bcfc5f300343b5.tar.bz2
aports-5b82ec46001681080d28e51dd2bcfc5f300343b5.tar.xz
testing/py3-pdfkit: rename from py-pdfkit
Diffstat (limited to 'testing/py3-pdfkit/APKBUILD')
-rw-r--r--testing/py3-pdfkit/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pdfkit/APKBUILD b/testing/py3-pdfkit/APKBUILD
new file mode 100644
index 0000000000..95ac1f477a
--- /dev/null
+++ b/testing/py3-pdfkit/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-pdfkit
+_pkgname=pdfkit
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Python wrapper to convert HTML to PDF using the WebKit rendering engine"
+url="https://github.com/JazzCore/python-pdfkit"
+arch="noarch"
+license="MIT"
+depends="wkhtmltopdf"
+makedepends="py-setuptools"
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --root "$pkgdir"
+}
+
+md5sums="5cbe42c43d463f0794272a01e37a553f py-pdfkit-0.5.0.zip"
+sha256sums="6e176cf460d8f8996d4c316aef1189e1c1c134d28d47a1e5e783e250ee3335dc py-pdfkit-0.5.0.zip"
+sha512sums="7d310d36503305bf71065b9b96bb313cb21f40ad7c347554b6f7a82e3d7ee8a7e3122ce54a522fbbacb5c50f0ddb72c9827bc0b38aa1ebea891e5c91b2668841 py-pdfkit-0.5.0.zip"