aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pdfkit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 21:17:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 00:19:19 -0300
commit62f4e35c24f6f99c5d618c48011cbdee2601f34f (patch)
tree9c085cbf62ba8ffc606c5b91c8b2e0e1713417bf /testing/py3-pdfkit
parent5b82ec46001681080d28e51dd2bcfc5f300343b5 (diff)
downloadaports-62f4e35c24f6f99c5d618c48011cbdee2601f34f.tar.bz2
aports-62f4e35c24f6f99c5d618c48011cbdee2601f34f.tar.xz
testing/py3-pdfkit: upgrade to 0.6.1
Diffstat (limited to 'testing/py3-pdfkit')
-rw-r--r--testing/py3-pdfkit/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/testing/py3-pdfkit/APKBUILD b/testing/py3-pdfkit/APKBUILD
index 95ac1f477a..64125b1f59 100644
--- a/testing/py3-pdfkit/APKBUILD
+++ b/testing/py3-pdfkit/APKBUILD
@@ -1,28 +1,28 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer:
-pkgname=py-pdfkit
+pkgname=py3-pdfkit
_pkgname=pdfkit
-pkgver=0.5.0
-pkgrel=1
+pkgver=0.6.1
+pkgrel=0
pkgdesc="Python wrapper to convert HTML to PDF using the WebKit rendering engine"
+options="!check" # No testsuite in pypi tarball, no github releases
url="https://github.com/JazzCore/python-pdfkit"
arch="noarch"
license="MIT"
-depends="wkhtmltopdf"
-makedepends="py-setuptools"
-source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+depends="wkhtmltopdf python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-pdfkit" # Backwards compatibility
+provides="py-pdfkit=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --root "$pkgdir"
+ python3 setup.py install --root "$pkgdir"
}
-md5sums="5cbe42c43d463f0794272a01e37a553f py-pdfkit-0.5.0.zip"
-sha256sums="6e176cf460d8f8996d4c316aef1189e1c1c134d28d47a1e5e783e250ee3335dc py-pdfkit-0.5.0.zip"
-sha512sums="7d310d36503305bf71065b9b96bb313cb21f40ad7c347554b6f7a82e3d7ee8a7e3122ce54a522fbbacb5c50f0ddb72c9827bc0b38aa1ebea891e5c91b2668841 py-pdfkit-0.5.0.zip"
+sha512sums="b3ac1016d1c01a2a196f567b9b672caca10f564cc6a62122691d34c3cbbf143f6a846bfba26c3474e9c0296977f0d30c0b5af13b3321ab207b787df3cba12e5d pdfkit-0.6.1.tar.gz"