aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pgspecial
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-27 23:22:31 +0300
committerprspkt <prspkt@protonmail.com>2019-04-28 00:19:24 +0300
commit28488964a6e65357819ab9327ae4b81fe9716617 (patch)
treee49a0987d358eedeefd3ed7fa0ce90cb4ee3fa28 /testing/py3-pgspecial
parent5d3da888fcc3adcd095937514ad63fc7031e28c8 (diff)
downloadaports-28488964a6e65357819ab9327ae4b81fe9716617.tar.bz2
aports-28488964a6e65357819ab9327ae4b81fe9716617.tar.xz
testing/py-pgspecial: drop python2
Diffstat (limited to 'testing/py3-pgspecial')
-rw-r--r--testing/py3-pgspecial/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-pgspecial/APKBUILD b/testing/py3-pgspecial/APKBUILD
new file mode 100644
index 0000000000..90d6f6636a
--- /dev/null
+++ b/testing/py3-pgspecial/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py3-pgspecial
+_pkgname=pgspecial
+pkgver=1.11.2
+pkgrel=1
+pkgdesc="Meta-commands handler for Postgres Database"
+url="https://pypi.python.org/pypi/pgspecial"
+arch="noarch"
+license="BSD-3-Clause"
+replaces="py-pgspecial py2-pgspecial"
+provides="py-pgspecial=$pkgver-r$pkgrel py2-pgspecial=$pkgver-r$pkgrel"
+depends="py3-click py3-sqlparse"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="58bf5ca3bd848a9f3010f91c02bdef84bc6ebbeeb2aa58062e64117a1e2cb9e56ffc9b10d179806a7293cbf5955be557395523567f54c29b22a610431b2ade61 py-pgspecial-1.11.2.tar.gz"