aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-piexif
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-10 22:49:37 +0300
committerprspkt <prspkt@protonmail.com>2019-06-10 23:31:09 +0300
commit6d0ec08836be5b30b8585d9410d35dcef09ea762 (patch)
tree7ac31d0439ede0c93404fce35224038fb3b01166 /testing/py3-piexif
parent483c26e371917f9cb18814478c8320b2f7bedcc0 (diff)
downloadaports-6d0ec08836be5b30b8585d9410d35dcef09ea762.tar.bz2
aports-6d0ec08836be5b30b8585d9410d35dcef09ea762.tar.xz
testing/py3-piexif: new aport
Diffstat (limited to 'testing/py3-piexif')
-rw-r--r--testing/py3-piexif/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-piexif/APKBUILD b/testing/py3-piexif/APKBUILD
new file mode 100644
index 0000000000..d3a1db4a95
--- /dev/null
+++ b/testing/py3-piexif/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-piexif
+_pkgname=piexif
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="EXIF manipulations with Python"
+url="https://github.com/hMatoba/Piexif"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pillow"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="045906fdbd49350866058bacafb61841030766bccb7d63ad3ee17ce9490858773c88e9fc86ca3e2985e752871e52b89778147d1b3d0abe5f1055d6cb02fc300d piexif-1.1.2.zip"