aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pika/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:09:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 11:17:52 -0300
commitb8de07726d1f5822da108cf2a864eb4d37c84e37 (patch)
treeb99c3d40679b8da9e2af6052212ea7f564409f42 /testing/py3-pika/APKBUILD
parent93083d4ca9ee1862f72ae46b50d24718a3ff8e70 (diff)
downloadaports-b8de07726d1f5822da108cf2a864eb4d37c84e37.tar.bz2
aports-b8de07726d1f5822da108cf2a864eb4d37c84e37.tar.xz
testing/py3-pika: rename from py-pika
Diffstat (limited to 'testing/py3-pika/APKBUILD')
-rw-r--r--testing/py3-pika/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-pika/APKBUILD b/testing/py3-pika/APKBUILD
new file mode 100644
index 0000000000..6f637fb5ef
--- /dev/null
+++ b/testing/py3-pika/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pika
+_pkgname=pika
+pkgver=0.9.14
+pkgrel=0
+pkgdesc="A Python AMQP client library"
+url="https://pika.readthedocs.org"
+arch="noarch"
+license="MPL-2.0"
+depends="python2 py-tornado py-twisted py-ev"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b99aad4b88961d3c7e4876b8327fc97c pika-0.9.14.tar.gz"
+sha256sums="5e2be3cb4ebdc267abd8e481c09bc30e95919a24e3a5f3f69744959490ead0e3 pika-0.9.14.tar.gz"
+sha512sums="c5b279c48341cef7b86d11414159de778afd3cf043d0ba8ba45adff6e8fbf72ec39642ed533c4d3674df3555fdaa0d7ff32a1844001bc56c1c380643d075870c pika-0.9.14.tar.gz"