aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pkgconfig
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 01:23:48 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 06:48:23 +0000
commit2b64d28747be147ee946d171d3744ca58669ac64 (patch)
tree637421bda226569c00714f56559f7897eae080dd /testing/py3-pkgconfig
parentd01df37a893be249b4271a9ce65891814f69fca9 (diff)
downloadaports-2b64d28747be147ee946d171d3744ca58669ac64.tar.bz2
aports-2b64d28747be147ee946d171d3744ca58669ac64.tar.xz
testing/py3-pkgconfig: new aport
Closes GH-8380
Diffstat (limited to 'testing/py3-pkgconfig')
-rw-r--r--testing/py3-pkgconfig/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-pkgconfig/APKBUILD b/testing/py3-pkgconfig/APKBUILD
new file mode 100644
index 0000000000..3ac019609f
--- /dev/null
+++ b/testing/py3-pkgconfig/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pkgconfig
+_realname=pkgconfig
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Python interface for the pkg-config command line tool"
+options="!check" # GitHub tarballs depend on unpackaged poetry build system
+url="https://github.com/matze/pkgconfig"
+arch="noarch"
+license="MIT"
+depends="python3 pkgconf"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1fd9aa973bd20a8fab864722598f1d19b94c23c7f2b522556b3182b19fe016bda7aa2be5e48a1b8fefa70a069611007d6d790e24defcb462e4594a382de85b00 pkgconfig-1.5.1.tar.gz"