aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-plac
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-05-22 12:35:16 -0500
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 05:52:19 -0300
commitd9dda14dfeec564d19c47cfa97db3b7245ef3f08 (patch)
tree7b1a1584b149540790d70e82c3f5bdb47dd52d31 /testing/py3-plac
parent6a477c1800bde358d2cede0fd23fb5a283677ca3 (diff)
downloadaports-d9dda14dfeec564d19c47cfa97db3b7245ef3f08.tar.bz2
aports-d9dda14dfeec564d19c47cfa97db3b7245ef3f08.tar.xz
testing/py3-plac: new aport
https://github.com/micheles/plac Parsing the command line the easy way
Diffstat (limited to 'testing/py3-plac')
-rw-r--r--testing/py3-plac/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-plac/APKBUILD b/testing/py3-plac/APKBUILD
new file mode 100644
index 0000000000..ad5242f5e0
--- /dev/null
+++ b/testing/py3-plac/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=py3-plac
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Parsing the command line the easy way"
+url="https://github.com/micheles/plac"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc"
+source="https://github.com/micheles/plac/archive/plac-$pkgver.tar.gz"
+builddir="$srcdir/plac-plac-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$(echo $PWD/build/lib)" pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
+}
+
+sha512sums="b43375688a8f23b2d847261ca5ef5beaa17d7017af01549f4bb36bc91912c4da5ac545962ae33b64686969d313f8240a25d9c4457a6207e5d7dfbd38bc4d514c plac-1.0.0.tar.gz"