aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pockethernet
diff options
context:
space:
mode:
authorMartijn Braam <martijn@brixit.nl>2019-10-09 12:00:17 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-09 13:32:13 +0200
commit5c8d2d4c42ce04a786f0d2378b9c03121c1bd576 (patch)
tree9d9ded1ccc898be1fbec2ace45957b3961294d5e /testing/py3-pockethernet
parent73267fa84b89948e437735bd555c2f87018ff599 (diff)
downloadaports-5c8d2d4c42ce04a786f0d2378b9c03121c1bd576.tar.bz2
aports-5c8d2d4c42ce04a786f0d2378b9c03121c1bd576.tar.xz
testing/py3-pockethernet: new aport
Python library for communication with pockethernet hardware.
Diffstat (limited to 'testing/py3-pockethernet')
-rw-r--r--testing/py3-pockethernet/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pockethernet/APKBUILD b/testing/py3-pockethernet/APKBUILD
new file mode 100644
index 0000000000..ba8aaa839d
--- /dev/null
+++ b/testing/py3-pockethernet/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Martijn Braam <martijn@brixit.nl>
+pkgname=py3-pockethernet
+_pyname=pockethernet
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Library for controlling the Pockethernet"
+url="https://gitlab.com/MartijnBraam/pockethernet-protocol"
+arch="noarch"
+license="MIT"
+depends="python3 py3-cobs py3-crc16"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="df8c438868a15e8e401a62b3033a6e81610fdb4d54a66be42a8691b965820f2e58ddf8a31a8334412f8decc0c771849f8c02798d64e71413a3b821365ed5e3cb pockethernet-0.2.1.tar.gz"