aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-prawcore
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 03:12:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:04:03 -0300
commitfcf7439f6052f5f0ba84fff9848255787c263bf3 (patch)
tree95722f62a96cc2d4020ba8e23348e50b0ccf2f4a /testing/py3-prawcore
parent318e38fe9f50ee23be155d0166d1d13bff52735a (diff)
downloadaports-fcf7439f6052f5f0ba84fff9848255787c263bf3.tar.bz2
aports-fcf7439f6052f5f0ba84fff9848255787c263bf3.tar.xz
testing/py3-prawcore: rebuild as python3 only
Diffstat (limited to 'testing/py3-prawcore')
-rw-r--r--testing/py3-prawcore/APKBUILD42
1 files changed, 5 insertions, 37 deletions
diff --git a/testing/py3-prawcore/APKBUILD b/testing/py3-prawcore/APKBUILD
index 6a5ad54d32..3fdac0c837 100644
--- a/testing/py3-prawcore/APKBUILD
+++ b/testing/py3-prawcore/APKBUILD
@@ -1,58 +1,26 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
-pkgname=py-prawcore
+pkgname=py3-prawcore
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="a low-level communication layer for PRAW 4+"
url="https://github.com/praw-dev/prawcore"
arch="noarch"
license="BSD-2-Clause"
-depends="py-setuptools"
-makedepends="python2-dev python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/praw-dev/prawcore/archive/v$pkgver.tar.gz"
builddir="$srcdir/prawcore-$pkgver"
build() {
- cd "$builddir"
-
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
-
- python2 setup.py test
python3 setup.py test
}
package() {
- cd "$builddir"
-
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-
-
-sha512sums="6efe8faa685aa92a04309c4c24963a2a540335ad0bed31b990d840732ddf726789688171f4ead4daf831e89da5c95c17861a079dfc9ae3de254d2690bcff1c8b py-prawcore-1.0.1.tar.gz"
+sha512sums="6efe8faa685aa92a04309c4c24963a2a540335ad0bed31b990d840732ddf726789688171f4ead4daf831e89da5c95c17861a079dfc9ae3de254d2690bcff1c8b py3-prawcore-1.0.1.tar.gz"