aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-precis-i18n
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-07-13 13:42:40 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 15:16:14 -0300
commitae1d4d290f07f5ff58824ecc507f7bf916320f72 (patch)
treea6c6c8ae8c0e28578200fc6de7c922778efdd0da /testing/py3-precis-i18n
parent3051f353aa059aaae8cb448c1df388092cb4c578 (diff)
downloadaports-ae1d4d290f07f5ff58824ecc507f7bf916320f72.tar.bz2
aports-ae1d4d290f07f5ff58824ecc507f7bf916320f72.tar.xz
testing/py3-precis-i18n: New aport
Internationalized Usernames and Passwords https://github.com/byllyfish/precis_i18n
Diffstat (limited to 'testing/py3-precis-i18n')
-rw-r--r--testing/py3-precis-i18n/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py3-precis-i18n/APKBUILD b/testing/py3-precis-i18n/APKBUILD
new file mode 100644
index 0000000000..d2c132c8b7
--- /dev/null
+++ b/testing/py3-precis-i18n/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-precis-i18n
+_pkgname=precis-i18n
+pkgver=1.0
+pkgrel=0
+pkgdesc="Internationalized Usernames and Passwords"
+url="https://github.com/byllyfish/precis_i18n"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="
+ $_pkgname-$pkgver.tar.gz::https://github.com/byllyfish/precis_i18n/archive/v${pkgver}.tar.gz
+ $_pkgname-$pkgver-derived-props-11.0.txt::https://github.com/byllyfish/precis_i18n/raw/f68b66a80fa36ff1004f5a88696edb424a75dd76/test/derived-props-11.0.txt
+ "
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+
+prepare() {
+ default_prepare
+ # Somehow one file required for the unit tests is not included in the release
+ cp "$srcdir"/$_pkgname-$pkgver-derived-props-11.0.txt "$builddir"/test/derived-props-11.0.txt
+}
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py test
+}
+sha512sums="b43622458fefb051e6f5ae6e347abfa65195052c63290b2be3ffb7c05eae0300caee53713d7216ee36c4ef0508cc4828e4d7ed3c65df873a684b803cc19bd410 precis-i18n-1.0.tar.gz
+df144b1790483055d9f6430c543892feed70402df6e0177daa94e005b5f9797f5885d7a5c1393a8a4555bcd0f7e85444f9e9f1152141b817f4e911bc2481e8bc precis-i18n-1.0-derived-props-11.0.txt"