aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-preshed
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-05-22 13:20:59 -0500
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 18:47:25 -0300
commita992b30ea1ecc78c302f5724059911d219d1601b (patch)
tree4abb7c2673fd374c9624bbed2a27517e541af81d /testing/py3-preshed
parent54b47ffe2c50ce32db7a7a258c022b9940f23b3d (diff)
downloadaports-a992b30ea1ecc78c302f5724059911d219d1601b.tar.bz2
aports-a992b30ea1ecc78c302f5724059911d219d1601b.tar.xz
testing/py3-preshed: new aport
https://github.com/explosion/preshed Cython hash tables that assume keys are pre-hashed
Diffstat (limited to 'testing/py3-preshed')
-rw-r--r--testing/py3-preshed/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py3-preshed/APKBUILD b/testing/py3-preshed/APKBUILD
new file mode 100644
index 0000000000..98f6a57c63
--- /dev/null
+++ b/testing/py3-preshed/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=py3-preshed
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Cython hash tables that assume keys are pre-hashed"
+url="https://github.com/explosion/preshed"
+arch="all"
+license="MIT"
+depends="python3 py3-cymem py3-murmurhash"
+makedepends="python3-dev py3-setuptools cython"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc"
+source="preshed-$pkgver.tar.gz::https://github.com/explosion/preshed/archive/v$pkgver.tar.gz"
+builddir="$srcdir/preshed-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py install --root="$PWD/tmp_install"
+
+ cd tmp_install/usr/lib/python3.8/site-packages
+
+ PYTHONPATH="$PWD/usr/lib" \
+ pytest-3 preshed
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+sha512sums="45e3a26491e5ce51e08e30c0acedaa8434e5c715022979c078dcf80e9b83cfb09c774e8f26aa02cb64b2ececd9f2b8e5b9d76fe81b69e6ad15a0d688345f4f20 preshed-3.0.2.tar.gz"