aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-py-radix
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-04 23:13:18 +0300
committerprspkt <prspkt@protonmail.com>2019-07-04 23:24:19 +0300
commit32cfcf4b6037ddb0e9a454ae1fab5e1ed662fd60 (patch)
treeb4f7809d95da669c4d9dee9ede1b28615e56f4fb /testing/py3-py-radix
parent3a29380de54e41f23c2c083c6e7f11ea9c7ed845 (diff)
downloadaports-32cfcf4b6037ddb0e9a454ae1fab5e1ed662fd60.tar.bz2
aports-32cfcf4b6037ddb0e9a454ae1fab5e1ed662fd60.tar.xz
testing/py-radix: drop python2
Diffstat (limited to 'testing/py3-py-radix')
-rw-r--r--testing/py3-py-radix/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py3-py-radix/APKBUILD b/testing/py3-py-radix/APKBUILD
new file mode 100644
index 0000000000..0576bda49a
--- /dev/null
+++ b/testing/py3-py-radix/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer: Kristóf Jakab <jakab.kristof@balasys.hu>
+pkgname=py3-py-radix
+_pkgname=py-radix
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="An implementation of a radix tree for Python"
+url="https://github.com/mjschultz/py-radix"
+arch="all"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools python3-dev"
+checkdepends="py3-coverage py3-nose"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mjschultz/py-radix/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+replaces=py-radix # Backwards compatibility
+provides=py-radix=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="b4b6a35aad76c19c2eaa5bff828cbec5182cc4074397d4b9e5c39ac76bd9045c86600ed52ac06632abac8a9e70d6e82aa9e741ab3eb92970453bb14acdba72ea py-radix-0.10.0.tar.gz"