aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyaes
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 21:42:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 21:42:13 -0300
commit6b8381c9b73fcb3a72dc008c1ea733728c471fb5 (patch)
tree0d08444d2a3f9cb405c08d57add97567d90ec4d8 /testing/py3-pyaes
parent54c0afa1a45a17f153a78376c8933119bf9ba11d (diff)
downloadaports-6b8381c9b73fcb3a72dc008c1ea733728c471fb5.tar.bz2
aports-6b8381c9b73fcb3a72dc008c1ea733728c471fb5.tar.xz
testing/py3-pyaes: new aport
https://github.com/ricmoo/pyaes Pure-Python Implementation of the AES block-cipher and common modes of operation
Diffstat (limited to 'testing/py3-pyaes')
-rw-r--r--testing/py3-pyaes/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pyaes/APKBUILD b/testing/py3-pyaes/APKBUILD
new file mode 100644
index 0000000000..3ec67c8a1c
--- /dev/null
+++ b/testing/py3-pyaes/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pyaes
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+url="https://github.com/ricmoo/pyaes"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pyaes/pyaes-$pkgver.tar.gz"
+builddir="$srcdir/pyaes-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="00ce3babf72ea18b0de369860cd884058c7c6f3bd8b961c3ff591ef7d3dc0a69fabad5311f61c9f91d2f1a480c8512e34eeced5ec7145ed9f963bf91c5f8838a pyaes-1.6.1.tar.gz"