aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycolorterm
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 04:30:34 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 19:16:54 +0200
commit27ee840ff2603b765e1bb7da92ca089bae23f0a0 (patch)
tree89dc03f5f84933d5adc6f5a518cba4420b4878eb /testing/py3-pycolorterm
parentf7f9fb595b4de3db4cc4e246d3587767d9d37f33 (diff)
downloadaports-27ee840ff2603b765e1bb7da92ca089bae23f0a0.tar.bz2
aports-27ee840ff2603b765e1bb7da92ca089bae23f0a0.tar.xz
testing/py-pycolorterm: upgrade to python3
Diffstat (limited to 'testing/py3-pycolorterm')
-rw-r--r--testing/py3-pycolorterm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-pycolorterm/APKBUILD b/testing/py3-pycolorterm/APKBUILD
new file mode 100644
index 0000000000..7ea203149f
--- /dev/null
+++ b/testing/py3-pycolorterm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pycolorterm
+_pkgname=pycolorterm
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="A Python module to work with color and style formatting"
+url="https://github.com/dnmellen/pycolorterm"
+arch="noarch"
+license="BSD"
+replaces="py-pycolorterm" # for backwards compatibility
+provides="py-pycolorterm=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+depends_dev=""
+makedepends="python3-dev py3-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="c90cb9a0fde94bbd856ba555bb5137004a3a936e028830938bdadf25be94a6f13a0597afb5439681c89d483806375708106be585c236109e83c3e493973e7d4a pycolorterm-0.2.1.tar.gz"