aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycolorterm
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 04:32:49 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 19:16:54 +0200
commitbe5c5d3630b8b2a8b13a70c54145a4376e4c5dcb (patch)
treef93c1e5a391220815545d8a51f694f190eb9183b /testing/py3-pycolorterm
parent27ee840ff2603b765e1bb7da92ca089bae23f0a0 (diff)
downloadaports-be5c5d3630b8b2a8b13a70c54145a4376e4c5dcb.tar.bz2
aports-be5c5d3630b8b2a8b13a70c54145a4376e4c5dcb.tar.xz
testing/py3-pycolorterm: clarify license, modernize
Diffstat (limited to 'testing/py3-pycolorterm')
-rw-r--r--testing/py3-pycolorterm/APKBUILD25
1 files changed, 6 insertions, 19 deletions
diff --git a/testing/py3-pycolorterm/APKBUILD b/testing/py3-pycolorterm/APKBUILD
index 7ea203149f..920c67d67b 100644
--- a/testing/py3-pycolorterm/APKBUILD
+++ b/testing/py3-pycolorterm/APKBUILD
@@ -7,35 +7,22 @@ pkgrel=0
pkgdesc="A Python module to work with color and style formatting"
url="https://github.com/dnmellen/pycolorterm"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
replaces="py-pycolorterm" # for backwards compatibility
provides="py-pycolorterm=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="c90cb9a0fde94bbd856ba555bb5137004a3a936e028830938bdadf25be94a6f13a0597afb5439681c89d483806375708106be585c236109e83c3e493973e7d4a pycolorterm-0.2.1.tar.gz"