aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pydocstyle
diff options
context:
space:
mode:
authorRuss Webber <russ@rw.id.au>2019-10-27 17:53:11 +1100
committerRasmus Thomsen <oss@cogitri.dev>2019-10-27 10:53:50 +0100
commitb400a8c9d330dd47bb5915650a2f2bae8c67fd68 (patch)
tree18b54cdd8e60b521cd505abc82045b8c8615ce79 /testing/py3-pydocstyle
parent5df6d7bdcf5b6ffc00df2a84fd3701eb4321bc5c (diff)
downloadaports-b400a8c9d330dd47bb5915650a2f2bae8c67fd68.tar.bz2
aports-b400a8c9d330dd47bb5915650a2f2bae8c67fd68.tar.xz
testing/py3-pydocstyle: new aport
Diffstat (limited to 'testing/py3-pydocstyle')
-rw-r--r--testing/py3-pydocstyle/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pydocstyle/APKBUILD b/testing/py3-pydocstyle/APKBUILD
new file mode 100644
index 0000000000..2d21ae4f17
--- /dev/null
+++ b/testing/py3-pydocstyle/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Russ Webber <russ@rw.id.au>
+# Maintainer: Russ Webber <russ@rw.id.au>
+pkgname="py3-pydocstyle"
+_pkgname="pydocstyle"
+pkgver="4.0.1"
+pkgrel=0
+pkgdesc="Static analysis tool for checking compliance with Python docstring conventions"
+url="https://pydocstyle.org/"
+arch="noarch"
+license="MIT"
+depends="python3 py3-snowballstemmer"
+makedepends="py3-setuptools py3-pytest py3-mock py3-six"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/PyCQA/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # integration tests call pip which doesn't exist
+ PYTHONPATH="$builddir/build/lib" py.test --deselect src/tests/test_integration.py -vv src/tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6d1b9d1eb46185a616a6715113542a41f1085296b162da563ed18086addd5f8f14dd30d6460cf105a3b0542fc0823f47214f1b329b9dfa0c4cf211cde700aa19 pydocstyle-4.0.1.tar.gz"