aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pydot
diff options
context:
space:
mode:
authorRuss Webber <russ@rw.id.au>2019-10-27 17:03:44 +1100
committerRasmus Thomsen <oss@cogitri.dev>2019-10-27 09:18:10 +0100
commit5526b231ce8880de086d2daa8c5dbd5be09cc738 (patch)
tree46e089ccbf109115674289e47af8709ed84efa2d /testing/py3-pydot
parent52371610853a2cc33f4bff3439692a0330926f65 (diff)
downloadaports-5526b231ce8880de086d2daa8c5dbd5be09cc738.tar.bz2
aports-5526b231ce8880de086d2daa8c5dbd5be09cc738.tar.xz
testing/py3-pydot: new aport
Diffstat (limited to 'testing/py3-pydot')
-rw-r--r--testing/py3-pydot/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-pydot/APKBUILD b/testing/py3-pydot/APKBUILD
new file mode 100644
index 0000000000..39d2208a66
--- /dev/null
+++ b/testing/py3-pydot/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Russ Webber <russ@rw.id.au>
+# Maintainer: Russ Webber <russ@rw.id.au>
+pkgname="py3-pydot"
+_pkgname="pydot"
+pkgver="1.4.1"
+pkgrel=0
+pkgdesc="Python interface to Graphviz's Dot language"
+url="https://github.com/pydot/pydot"
+arch="noarch"
+license="MIT"
+options="!check" # graphviz unable to parse jpe files
+depends="python3 py3-parsing"
+makedepends="py3-setuptools" # required for test: py3-chardet graphviz
+source="$_pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir/test"
+ PYTHONPATH="$builddir/build/lib" python3 pydot_unittest.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b5f16b59908586df61cd415cb1a3e242fb69c39674a82b171862beff1f3727f47cba39bdd806901cb56bc8a6888783a53d112b1b70044e124ea992789d77f938 pydot-1.4.1.tar.gz"