aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyftpdlib/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-07 02:55:04 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-20 10:02:47 -0300
commit79ae3aaf9ae5fbcbc7e11442f6440de2a87006da (patch)
tree5c39e233d6f1bd4abe030f6a8fea85ef238de37b /testing/py3-pyftpdlib/APKBUILD
parent92b55871b837ca83f38989e3a612f128ed1cebbc (diff)
downloadaports-79ae3aaf9ae5fbcbc7e11442f6440de2a87006da.tar.bz2
aports-79ae3aaf9ae5fbcbc7e11442f6440de2a87006da.tar.xz
testing/py3-pyftpdlib: new aport
Diffstat (limited to 'testing/py3-pyftpdlib/APKBUILD')
-rw-r--r--testing/py3-pyftpdlib/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-pyftpdlib/APKBUILD b/testing/py3-pyftpdlib/APKBUILD
new file mode 100644
index 0000000000..09386b675f
--- /dev/null
+++ b/testing/py3-pyftpdlib/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer:
+pkgname=py3-pyftpdlib
+_pkgname=${pkgname#py3-}
+pkgver=1.5.5
+pkgrel=0
+pkgdesc="Extremely fast and scalable Python FTP server library."
+url="https://pypi.org/project/pyftpdlib/"
+arch="noarch"
+license="MIT"
+# v1.5.5 two failing tests https://github.com/giampaolo/pyftpdlib/issues/500
+options="!check"
+depends="py3-openssl py3-pysendfile"
+makedepends="py3-setuptools"
+checkdepends="py3-psutil"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="27427154f893812f689adf3a9ceb4ec2d8f0ea7a4bf7b08671dc146c95f09ddd596a27c85e009d8d6647277def48c0bf0a8b76fb3fba5818eda3dfdc6c10795e pyftpdlib-1.5.5.tar.gz"