aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pygal
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 09:39:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 09:39:01 -0300
commitc46f5e02a5bf66a93ba99a63f33502def0ecdb58 (patch)
tree5deb3aabefba286cf897f7ab6e2841ae92fcf53b /testing/py3-pygal
parentf8a5fc733ec60617c1be9bd13a08d769f5e798e4 (diff)
downloadaports-c46f5e02a5bf66a93ba99a63f33502def0ecdb58.tar.bz2
aports-c46f5e02a5bf66a93ba99a63f33502def0ecdb58.tar.xz
testing/py3-pygal: rename from py-pygal
Diffstat (limited to 'testing/py3-pygal')
-rw-r--r--testing/py3-pygal/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py3-pygal/APKBUILD b/testing/py3-pygal/APKBUILD
new file mode 100644
index 0000000000..ab0fb1b5b4
--- /dev/null
+++ b/testing/py3-pygal/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-pygal
+_pkgname=pygal
+pkgver=2.4.0
+pkgrel=2
+pkgdesc="pygal is a dynamic SVG charting library written in python"
+url="https://pygal.org"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="py-setuptools"
+makedepends="python2-dev python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5cb95ca5c0cf74ae476953f3503154a305a0b5e42c69191b0b46f6e6cfea8c806713fe175329a69b393654d055997b2063cf3b641e91009a2b7bef219bb49ddb pygal-2.4.0.tar.gz"