aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pylev
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 02:27:11 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commit334f910df0a0d434061c7004cba80f27206bb355 (patch)
treeb2ec7d0fda2c284df4760bbe524f04b332a93d2a /testing/py3-pylev
parent1a50dd67e74bda933b3926d6e890e3c639675d41 (diff)
downloadaports-334f910df0a0d434061c7004cba80f27206bb355.tar.bz2
aports-334f910df0a0d434061c7004cba80f27206bb355.tar.xz
testing/py3-pylev: new aport
Pure Python3 Levenshtein implementation https://github.com/toastdriven/pylev Closes GH-8381
Diffstat (limited to 'testing/py3-pylev')
-rw-r--r--testing/py3-pylev/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-pylev/APKBUILD b/testing/py3-pylev/APKBUILD
new file mode 100644
index 0000000000..ae4a93da1c
--- /dev/null
+++ b/testing/py3-pylev/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pylev
+_realname=pylev
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Pure Python3 Levenshtein implementation"
+options="!check" # No tests on pypi, no tags on github
+url="https://github.com/toastdriven/pylev"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="096831d55dda5606544bce03c18542b0331c38feb538dd37c67cc2e9b2111d381632669ee2dcd3d7dc9a87d284892371ded1c322d0edc61f529152c282556f4c pylev-1.3.0.tar.gz"