aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pylint/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-30 00:45:20 +0300
committerprspkt <prspkt@protonmail.com>2019-05-30 21:30:42 +0300
commit5602546843ce2270fd5e594dcf69568da321a128 (patch)
tree8ba1a117b08e2c56e3601051252757c22c5f0a9f /testing/py3-pylint/APKBUILD
parentbcb037f3920a69b761694e61a22917195e5eea7c (diff)
downloadaports-5602546843ce2270fd5e594dcf69568da321a128.tar.bz2
aports-5602546843ce2270fd5e594dcf69568da321a128.tar.xz
testing/py3-pylint: upgrade to 2.3.1
- Add checkdepends and enable test suite.
Diffstat (limited to 'testing/py3-pylint/APKBUILD')
-rw-r--r--testing/py3-pylint/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/py3-pylint/APKBUILD b/testing/py3-pylint/APKBUILD
index 6c35a3def2..4849fbd582 100644
--- a/testing/py3-pylint/APKBUILD
+++ b/testing/py3-pylint/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pylint
_pkgname=pylint
-pkgver=1.7.4
-pkgrel=2
+pkgver=2.3.1
+pkgrel=0
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="https://github.com/PyCQA/pylint"
arch="noarch"
license="GPL-2.0-or-later"
depends="py3-astroid py3-isort py3-mccabe py3-setuptools"
+checkdepends="mpdecimal py3-pytest py3-pytest-runner"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -16,8 +17,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py pytest
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="c1d671e53141df9fbe55a0e285bb6f5199c2a778f56759c41292835cbad7cb4aa4b6152116d85aa9b77cbbabd15d2b8573fa2e86accd2b243e96175abd2b2bf1 pylint-1.7.4.tar.gz"
+sha512sums="924d8adc95f04ba750b3b44fe79ac569151ea7c8f693cc9867bcda3878209ebc2202931702b98f80709d161d3781b6e181aea0ded35a3323c023497e2a749ea9 pylint-2.3.1.tar.gz"