aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pylint
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-30 00:38:06 +0300
committerprspkt <prspkt@protonmail.com>2019-05-30 21:25:24 +0300
commitbcb037f3920a69b761694e61a22917195e5eea7c (patch)
tree0de9326cbc15fbd363c978b1ac539b7e4ab58b2f /testing/py3-pylint
parenta33abb82a41c60bcf4ae09edb6daa7c92e160013 (diff)
downloadaports-bcb037f3920a69b761694e61a22917195e5eea7c.tar.bz2
aports-bcb037f3920a69b761694e61a22917195e5eea7c.tar.xz
testing/pylint: drop python2
Diffstat (limited to 'testing/py3-pylint')
-rw-r--r--testing/py3-pylint/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py3-pylint/APKBUILD b/testing/py3-pylint/APKBUILD
new file mode 100644
index 0000000000..6c35a3def2
--- /dev/null
+++ b/testing/py3-pylint/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pylint
+_pkgname=pylint
+pkgver=1.7.4
+pkgrel=2
+pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
+url="https://github.com/PyCQA/pylint"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="py3-astroid py3-isort py3-mccabe py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c1d671e53141df9fbe55a0e285bb6f5199c2a778f56759c41292835cbad7cb4aa4b6152116d85aa9b77cbbabd15d2b8573fa2e86accd2b243e96175abd2b2bf1 pylint-1.7.4.tar.gz"