aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pymysql
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 19:38:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 19:44:23 -0300
commita3057eeaedebcd513f2d79c8547f4cf8df5ee6a7 (patch)
treeff394275232afde57f83ad9465335c509bc1ace8 /testing/py3-pymysql
parentee0b3db64525868587cd3d7b2a9336dc6487bbc9 (diff)
downloadaports-a3057eeaedebcd513f2d79c8547f4cf8df5ee6a7.tar.bz2
aports-a3057eeaedebcd513f2d79c8547f4cf8df5ee6a7.tar.xz
testing/py3-pymysql: rename from py-pymysql
Diffstat (limited to 'testing/py3-pymysql')
-rw-r--r--testing/py3-pymysql/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py3-pymysql/APKBUILD b/testing/py3-pymysql/APKBUILD
new file mode 100644
index 0000000000..ec7d941371
--- /dev/null
+++ b/testing/py3-pymysql/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-pymysql
+_pkgname=PyMySQL
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Pure Python MySQL Client"
+url="https://pypi.python.org/pypi/PyMySQL"
+arch="noarch"
+license="MIT"
+options="!check" #require mysql for tests
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="4918802808fb12417db682831290adfa5a785ca34da5674b7a8ccc7c942a1de424c3085282912df326131e978daf771d71c6b33aeb3cb2590c70b5ff6e557b07 py-pymysql-0.9.2.tar.gz"