aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pynvim
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-11-21 00:11:37 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 09:21:49 +0100
commit8836fb8c1b8c9fa30fd524f564e15739e7a14f75 (patch)
treeae01a639ad6a76a04a71c3fe1408b61a854897f2 /testing/py3-pynvim
parent96acef60c9151088282c9cfee2085369f44d4855 (diff)
downloadaports-8836fb8c1b8c9fa30fd524f564e15739e7a14f75.tar.bz2
aports-8836fb8c1b8c9fa30fd524f564e15739e7a14f75.tar.xz
testing/py3-pynvim: new aport
https://github.com/neovim/pynvim python client and plugin host for Nvim testing/
Diffstat (limited to 'testing/py3-pynvim')
-rw-r--r--testing/py3-pynvim/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pynvim/APKBUILD b/testing/py3-pynvim/APKBUILD
new file mode 100644
index 0000000000..41fbc5f75e
--- /dev/null
+++ b/testing/py3-pynvim/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="py3-pynvim"
+_pyname="pynvim"
+pkgver="0.4.0"
+pkgrel=0
+pkgdesc="python client and plugin host for Nvim"
+url="https://github.com/neovim/pynvim"
+arch="noarch"
+license="Apache"
+depends="python3 py3-msgpack py3-greenlet"
+makedepends="python3-dev"
+source="$_pyname-$pkgver.tar.gz::https://github.com/neovim/$_pyname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="4b3b0e295181cf8886850477d01daba1cba8ac456aedadc5b3881b0b4910724450c4e7774282f6edf3e322792b697ae8e925f40b2a0b181a95eee48aef42a97a pynvim-0.4.0.tar.gz"