aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-controllers
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:24:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:36:33 -0300
commit479fc71eab411fc5aa8e6afe92474cf9f686daf4 (patch)
treed5897cd48f617ef9548a51d1f3f830ef6a8a8a57 /testing/py3-pyramid-controllers
parente48d39f9de7e0349b3ebf270e50e94e971d53ced (diff)
downloadaports-479fc71eab411fc5aa8e6afe92474cf9f686daf4.tar.bz2
aports-479fc71eab411fc5aa8e6afe92474cf9f686daf4.tar.xz
testing/py3-pyramid-controllers: rename from py-pyramid-controllers
Diffstat (limited to 'testing/py3-pyramid-controllers')
-rw-r--r--testing/py3-pyramid-controllers/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-pyramid-controllers/APKBUILD b/testing/py3-pyramid-controllers/APKBUILD
new file mode 100644
index 0000000000..040ba8e31a
--- /dev/null
+++ b/testing/py3-pyramid-controllers/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-controllers
+_pkgname=pyramid_controllers
+pkgver=0.3.22
+pkgrel=0
+pkgdesc="A pyramid plugin that provides de-centralized hierarchical object dispatch"
+url="http://github.com/cadithealth/pyramid_controllers"
+arch="noarch"
+license="MIT"
+depends="python2 py-pyramid"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="3e445fa2c461367e5c611fa9b5193a61 pyramid_controllers-0.3.22.tar.gz"
+sha256sums="8da9a60727cb56c29080f3b12474800931158235ac8485cdc7f7301b69bce03b pyramid_controllers-0.3.22.tar.gz"
+sha512sums="e2a6715d00ce871e61f193c4a9ce96c11a0ed515605aec27a83778af7c343bf890f38a79a367a3278628a73883806a1d15a8c773287425bd5e1011c57fb09531 pyramid_controllers-0.3.22.tar.gz"