aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-controllers
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:25:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:36:33 -0300
commit3d3b0f642d0408c9b24230e4721a35b703fb1e71 (patch)
tree1c3e9322423950d0bac587fc34fa02d8aa64bc7b /testing/py3-pyramid-controllers
parent479fc71eab411fc5aa8e6afe92474cf9f686daf4 (diff)
downloadaports-3d3b0f642d0408c9b24230e4721a35b703fb1e71.tar.bz2
aports-3d3b0f642d0408c9b24230e4721a35b703fb1e71.tar.xz
testing/py3-pyramid-controllers: drop py2
Diffstat (limited to 'testing/py3-pyramid-controllers')
-rw-r--r--testing/py3-pyramid-controllers/APKBUILD30
1 files changed, 8 insertions, 22 deletions
diff --git a/testing/py3-pyramid-controllers/APKBUILD b/testing/py3-pyramid-controllers/APKBUILD
index 040ba8e31a..1ad9b3ee19 100644
--- a/testing/py3-pyramid-controllers/APKBUILD
+++ b/testing/py3-pyramid-controllers/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pyramid-controllers
+pkgname=py3-pyramid-controllers
_pkgname=pyramid_controllers
pkgver=0.3.22
pkgrel=0
@@ -8,34 +8,20 @@ pkgdesc="A pyramid plugin that provides de-centralized hierarchical object dispa
url="http://github.com/cadithealth/pyramid_controllers"
arch="noarch"
license="MIT"
-depends="python2 py-pyramid"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="python3 py3-pyramid"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-pyramid-controllers" # Backwards compatibility
+provides="py-pyramid-controllers=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="3e445fa2c461367e5c611fa9b5193a61 pyramid_controllers-0.3.22.tar.gz"
-sha256sums="8da9a60727cb56c29080f3b12474800931158235ac8485cdc7f7301b69bce03b pyramid_controllers-0.3.22.tar.gz"
sha512sums="e2a6715d00ce871e61f193c4a9ce96c11a0ed515605aec27a83778af7c343bf890f38a79a367a3278628a73883806a1d15a8c773287425bd5e1011c57fb09531 pyramid_controllers-0.3.22.tar.gz"