aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:06:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:23:54 -0300
commit943eb83e70708888a0fe2fc55705be680ecc2753 (patch)
tree298d13872d8c5a00bad25074cb17b05b671303e3 /testing/py3-pyramid
parentaed7da28f6287f73ba2e97861ce90ad2da74c276 (diff)
downloadaports-943eb83e70708888a0fe2fc55705be680ecc2753.tar.bz2
aports-943eb83e70708888a0fe2fc55705be680ecc2753.tar.xz
testing/py3-pyramid: rename from py-pyramid
Diffstat (limited to 'testing/py3-pyramid')
-rw-r--r--testing/py3-pyramid/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pyramid/APKBUILD b/testing/py3-pyramid/APKBUILD
new file mode 100644
index 0000000000..8d119face4
--- /dev/null
+++ b/testing/py3-pyramid/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid
+_pkgname=pyramid
+pkgver=1.7
+pkgrel=0
+pkgdesc="The Pyramid Web Framework"
+url="http://www.pylonsproject.org/"
+arch="noarch"
+license="BSD"
+depends="py-webob py-repoze-lru py-venusian py-chameleon py-zope-component
+ py-zope-deprecation py-zope-configuration py-translationstring"
+makedepends="python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="acc2c511d0c4ab3281cffe307f849618 pyramid-1.7.tar.gz"
+sha256sums="26f6b126f76a5ade38a5c1c2004ebd5ed52a30a014b329001e96627c36533898 pyramid-1.7.tar.gz"
+sha512sums="91ae002a00872a93861b94840e8f881595550a8d669bb5cadaf18e1b2946f30e070bed012e6368d9126c0263305424af0076b3c9ac9dc0792955a06e976df783 pyramid-1.7.tar.gz"