aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyro4/APKBUILD
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-06-05 19:44:40 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-06-09 13:02:39 -0300
commit44d4d50c8db093bafea973eb66b4b581983ffefe (patch)
tree8a3482d17157ea72af81bfeea35b2dd5d5066183 /testing/py3-pyro4/APKBUILD
parentf122162f8642c27792edb72a4637123020c0c20a (diff)
downloadaports-44d4d50c8db093bafea973eb66b4b581983ffefe.tar.bz2
aports-44d4d50c8db093bafea973eb66b4b581983ffefe.tar.xz
testing/py3-pyro4: update to 4.76, drop Python 2
Diffstat (limited to 'testing/py3-pyro4/APKBUILD')
-rw-r--r--testing/py3-pyro4/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-pyro4/APKBUILD b/testing/py3-pyro4/APKBUILD
new file mode 100644
index 0000000000..616639d7e6
--- /dev/null
+++ b/testing/py3-pyro4/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-pyro4
+_pyname=Pyro4
+pkgver=4.76
+pkgrel=0
+pkgdesc="Python remote objects"
+url="http://pyro4.readthedocs.io/"
+arch="noarch"
+license="MIT"
+depends="py3-serpent"
+makedepends="python3 py3-setuptools"
+checkdepends="py3-msgpack py3-dill py3-cloudpickle"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+replaces="py-pyro4 py2-pyro4"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="48cc63bc74d483fff1b4bac2dd9ecf7576503bfd91e721512a5cea2b5a115ad6480ad0524218aee31e412a867261a9e838d85650dd0f7a87593a4a03cfc5cdc3 Pyro4-4.76.tar.gz"