aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyro4
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 21:26:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 21:26:49 -0300
commit8781ffb48b48ecb9a5f548a8b473113c381c5b4a (patch)
treebe5f5513d95d21fded2112622ebb0f75ee82b22d /testing/py3-pyro4
parent19115ccb505928cf94c166c21f94e062dea3e426 (diff)
downloadaports-8781ffb48b48ecb9a5f548a8b473113c381c5b4a.tar.bz2
aports-8781ffb48b48ecb9a5f548a8b473113c381c5b4a.tar.xz
testing/py3-pyro4: fix provides and replaces
Diffstat (limited to 'testing/py3-pyro4')
-rw-r--r--testing/py3-pyro4/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/py3-pyro4/APKBUILD b/testing/py3-pyro4/APKBUILD
index a4395b8b47..e9f29474ab 100644
--- a/testing/py3-pyro4/APKBUILD
+++ b/testing/py3-pyro4/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py3-pyro4
_pyname=Pyro4
pkgver=4.76
-pkgrel=0
+pkgrel=1
pkgdesc="Python remote objects"
url="http://pyro4.readthedocs.io/"
arch="noarch !s390x" # Limited by py3-dill
@@ -13,7 +13,9 @@ checkdepends="py3-msgpack py3-dill py3-cloudpickle"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir=$srcdir/$_pyname-$pkgver
-replaces="py-pyro4 py2-pyro4"
+
+replaces="py-pyro4" # Backwards compatibility
+provides="py-pyro4=$pkgver-r$pkgrel" # Backwards compatibility
build() {
python3 setup.py build