aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyscard
diff options
context:
space:
mode:
authorDaniel Everett <deverett@gmail.com>2018-09-02 04:31:01 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 05:47:30 +0000
commitfc9081e4197bb81ef1b9d1de204ba6fe56899d98 (patch)
tree3f109d90335f1ba36e99648f42b02548c28bb573 /testing/py3-pyscard
parentf67c498b9d45004ac18e3929e5f3578c9893b99f (diff)
downloadaports-fc9081e4197bb81ef1b9d1de204ba6fe56899d98.tar.bz2
aports-fc9081e4197bb81ef1b9d1de204ba6fe56899d98.tar.xz
testing/pyscard: new aport
https://github.com/LudovicRousseau/pyscard/blob/master/LICENSE pyscard smartcard library for python
Diffstat (limited to 'testing/py3-pyscard')
-rw-r--r--testing/py3-pyscard/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pyscard/APKBUILD b/testing/py3-pyscard/APKBUILD
new file mode 100644
index 0000000000..bf4627e101
--- /dev/null
+++ b/testing/py3-pyscard/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Daniel Everett <deverett@gmail.com>
+# Maintainer: Daniel Everett <deverett@gmail.com>
+pkgname=py3-pyscard
+_pkgname=pyscard
+pkgver=1.9.7
+pkgrel=0
+pkgdesc="pyscard smartcard library for python"
+url="https://github.com/LudovicRousseau/pyscard"
+arch="all"
+license="LGPL-2.1-only"
+depends="pcsc-lite"
+makedepends="python2-dev python3-dev py-setuptools swig pcsc-lite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py test
+}
+
+sha512sums="339d6efd5fcaa361e30029e736d4e2e98e05acd701c39574b40960b4bcec4782ca9c1d6927cea0b3641c5e6a137d0b9fbd961b58422a4151cfbdfa067dcd4b4a pyscard-1.9.7.tar.gz"