aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pystache
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-30 07:55:15 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 19:04:00 +0000
commit48eb870251fefb4d1501a00fbb9797f4c0f8ec7c (patch)
tree24c1ed159ec45b3908644345d44ac3c9de15d6ea /testing/py3-pystache
parentb65a9c1871078df908c9e54b82d8715ca7b03ec8 (diff)
downloadaports-48eb870251fefb4d1501a00fbb9797f4c0f8ec7c.tar.bz2
aports-48eb870251fefb4d1501a00fbb9797f4c0f8ec7c.tar.xz
testing/py3-pystache: rename from py-pystache
Diffstat (limited to 'testing/py3-pystache')
-rw-r--r--testing/py3-pystache/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-pystache/APKBUILD b/testing/py3-pystache/APKBUILD
new file mode 100644
index 0000000000..33f085afbf
--- /dev/null
+++ b/testing/py3-pystache/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Paul Kilar <pkilar@gmail.com>
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Paul Kilar <pkilar@gmail.com>
+pkgname=py-pystache
+_realname=pystache
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Pystache is a Python implementation of Mustache."
+url="https://pypi.python.org/pypi/pystache"
+arch="noarch"
+license="MIT"
+options="!check"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ default_prepare
+ cp -r "$builddir" "$builddir-py3"
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ cd "$builddir-py3"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ cd "$builddir"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ cd "$builddir-py3"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="4ac325e1431f58f740218c9ec309821db82d89989ef4ca7fc3536dea0ef1c90e8e85ebaa7df27f33129ca02252b84bcbd7429a1ed999b496f62f174dd66502cb pystache-0.5.4.tar.gz"