aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pystache
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-05 12:47:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:35:42 +0000
commit6e7aeecc463a8301916d1795603af534489f86b2 (patch)
tree4fe6b2c57666e5b109a804363d40c9e8a767aa3e /testing/py3-pystache
parent337698e69463d8cf0bff5f8de1025ef4dcdc7b85 (diff)
downloadaports-6e7aeecc463a8301916d1795603af534489f86b2.tar.bz2
aports-6e7aeecc463a8301916d1795603af534489f86b2.tar.xz
testing/py3-pystache: rebuild against python 3.8
Diffstat (limited to 'testing/py3-pystache')
-rw-r--r--testing/py3-pystache/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-pystache/APKBUILD b/testing/py3-pystache/APKBUILD
index dfd5fced34..5e20ee3996 100644
--- a/testing/py3-pystache/APKBUILD
+++ b/testing/py3-pystache/APKBUILD
@@ -5,7 +5,7 @@
pkgname=py3-pystache
_realname=pystache
pkgver=0.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Pystache is a Python implementation of Mustache."
url="https://pypi.python.org/pypi/pystache"
arch="noarch"
@@ -23,9 +23,10 @@ build() {
check() {
# This package uses 2to3 to convert itself to Python 3 on the fly
# So we need to jump through some hoops here
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
mkdir -p test_dir
python3 setup.py install --root=test_dir
- PYTHONPATH=test_dir/usr/lib/python3.7/site-packages test_dir/usr/bin/pystache-test
+ PYTHONPATH=test_dir/usr/lib/python$_py3ver/site-packages test_dir/usr/bin/pystache-test
}
package() {