aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pytest-expect
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-02-29 18:08:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-29 20:58:58 -0300
commit0d154b0ee5f09425702bf61530a5c82371139059 (patch)
tree1604ae15c4eaa2e98ee792ae47469d22d693c89a /testing/py3-pytest-expect
parente4159e14c5ca8d7f214c675c9675dab8f35561b4 (diff)
downloadaports-0d154b0ee5f09425702bf61530a5c82371139059.tar.bz2
aports-0d154b0ee5f09425702bf61530a5c82371139059.tar.xz
testing/py3-pytest-expect: rename from pytest-expect
Diffstat (limited to 'testing/py3-pytest-expect')
-rw-r--r--testing/py3-pytest-expect/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-pytest-expect/APKBUILD b/testing/py3-pytest-expect/APKBUILD
new file mode 100644
index 0000000000..44f6c2efe4
--- /dev/null
+++ b/testing/py3-pytest-expect/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+pkgname=py3-pytest-expect
+_pkgname=pytest-expect
+pkgver=1.1.0
+pkgrel=4
+pkgdesc="A pytest plugin that stores test expectations"
+options="!check" # no test suite
+url="https://github.com/gsnedders/pytest-expect"
+arch="noarch"
+license="MIT"
+depends="py3-pytest py3-u-msgpack"
+makedepends="py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/gsnedders/pytest-expect/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dbef3c394e974663179e91ca3cd6f096fdb055693b3e540dd0f27d6bf59a5c7298144598eb069f8f0acddd82ecce0bdce14ccd25728eb6a024d41895403e5144 pytest-expect-1.1.0.tar.gz"