aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pytest-isort
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-06-30 14:24:31 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 04:04:12 -0300
commit408e28fe9dd5970df58950f7fa449c2f0ce77ccc (patch)
treec64557aa11aa6a2dedc6d39b8dff707fee6eb6eb /testing/py3-pytest-isort
parent4113433af460b61aaedfe1292ceef360ad6ab96b (diff)
downloadaports-408e28fe9dd5970df58950f7fa449c2f0ce77ccc.tar.bz2
aports-408e28fe9dd5970df58950f7fa449c2f0ce77ccc.tar.xz
testing/py3-pytest-isort: new APKBUILD
Diffstat (limited to 'testing/py3-pytest-isort')
-rw-r--r--testing/py3-pytest-isort/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pytest-isort/APKBUILD b/testing/py3-pytest-isort/APKBUILD
new file mode 100644
index 0000000000..6faaf10d83
--- /dev/null
+++ b/testing/py3-pytest-isort/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-pytest-isort
+_pyname=pytest-isort
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="pytest plugin to check import ordering using isort"
+url="https://pypi.org/project/pytest-isort/"
+arch="noarch"
+license="3-Clause-BSD"
+depends="py3-pytest py3-isort"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ export PYTHONPATH="$(pwd)"
+ pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2fd39108a6acacf18ce68bb537d2adeb4ff7cd8ea4c9611e5312edea5a0bc4841111ffb544318aa7b3bebe38e9f4744f07a45b2ebcbf872f79003b249ee115ca pytest-isort-0.3.1.tar.gz"