aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-python-editor
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-12 15:48:43 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-12 18:14:36 +0100
commit344e9aa9be28ce9534de4b347b889d598cc0c730 (patch)
treea6ad5f5bcb96d14b120e7e9d65c9a9b0155ec7b1 /testing/py3-python-editor
parentfb629585fece9d7051db690f07fb9359ba114772 (diff)
downloadaports-344e9aa9be28ce9534de4b347b889d598cc0c730.tar.bz2
aports-344e9aa9be28ce9534de4b347b889d598cc0c730.tar.xz
testing/py3-python-editor: new aport
https://github.com/fmoo/python-editor Programmatically open an editor, capture the result
Diffstat (limited to 'testing/py3-python-editor')
-rw-r--r--testing/py3-python-editor/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-python-editor/APKBUILD b/testing/py3-python-editor/APKBUILD
new file mode 100644
index 0000000000..6f7a8a0d00
--- /dev/null
+++ b/testing/py3-python-editor/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-python-editor
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="Programmatically open an editor, capture the result"
+url="https://github.com/fmoo/python-editor"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+options="!check" # tests are interactive
+source="https://files.pythonhosted.org/packages/source/p/python-editor/python-editor-$pkgver.tar.gz"
+builddir="$srcdir/python-editor-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6 python-editor-1.0.4.tar.gz"