aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-python-gssapi
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 19:54:31 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 19:55:04 +0000
commit4c3e9c89a3c46713c33b06e1a83a87638e725eef (patch)
tree6937533d99274c01583000b39eebd1374b35780c /testing/py3-python-gssapi
parent19c2e041afa80b498d0756e085ce9f904da3c0ed (diff)
downloadaports-4c3e9c89a3c46713c33b06e1a83a87638e725eef.tar.bz2
aports-4c3e9c89a3c46713c33b06e1a83a87638e725eef.tar.xz
testing/py3-python-gssapi: move from community
New packages should start in testing. This has been accidentally committed in community. Ref: GH-8400
Diffstat (limited to 'testing/py3-python-gssapi')
-rw-r--r--testing/py3-python-gssapi/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-python-gssapi/APKBUILD b/testing/py3-python-gssapi/APKBUILD
new file mode 100644
index 0000000000..d4252e7a4e
--- /dev/null
+++ b/testing/py3-python-gssapi/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py3-python-gssapi
+_pkgname=gssapi
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="A Python interface to RFC 2743/2744 (plus common extensions)"
+url="https://github.com/pythongssapi/python-gssapi"
+arch="all"
+license="ISC"
+depends="python3"
+#checkdepends="py-nose py-shouldbe py-k5test" # Tests are missing alpine packages
+makedepends="python3-dev krb5-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+#check() {
+# python3 setup.py test
+#}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d0c27360e1f54a322f311f102ad498a3794e5f22aa9e07f917fa074d02f1643932ba34d630761c62500e5f780a5c6b207ee4662507ca88f99fcfd4563d7241b0 gssapi-1.5.1.tar.gz"