aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-python-mystrom
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-20 00:00:00 +0300
committerprspkt <prspkt@protonmail.com>2019-08-20 00:08:55 +0300
commit4285f8da43675fa378ac1282ef04d7f9d57a7d57 (patch)
tree82eb9888c6df72d7674248f9560f8f7fa5543fde /testing/py3-python-mystrom
parent75af9adb6f8c879b84e5962b307cc92007dcdc73 (diff)
downloadaports-4285f8da43675fa378ac1282ef04d7f9d57a7d57.tar.bz2
aports-4285f8da43675fa378ac1282ef04d7f9d57a7d57.tar.xz
testing/py-mystrom: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'testing/py3-python-mystrom')
-rw-r--r--testing/py3-python-mystrom/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-python-mystrom/APKBUILD b/testing/py3-python-mystrom/APKBUILD
new file mode 100644
index 0000000000..674a378ef4
--- /dev/null
+++ b/testing/py3-python-mystrom/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-python-mystrom
+_pkgname=python-mystrom
+pkgver=0.3.8
+pkgrel=1
+pkgdesc="Python API for controlling myStrom switches/plugs"
+url="https://github.com/fabaff/python-mystrom"
+arch="noarch"
+license="MIT"
+depends="py3-requests"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-mystrom # Backwards compatibility
+provides=py-mystrom=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ac28df4d80ac5754234233def2131cb38073f4c4ec9301b5b40d17ea984cec6c06b354916b87bdbaee1693ed7c4adeeb575a5a618dde9c04412361973f3f76e0 python-mystrom-0.3.8.tar.gz"