aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyzor
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:36:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:47:35 -0300
commit1ebd0ed3dbe742d87d68fcefc8dc6dc35cb54390 (patch)
tree62247325ca156bb402eefd53ca1e690d76b8462d /testing/py3-pyzor
parent1780e3bd37ed881612a3839490bb906440bc5f2d (diff)
downloadaports-1ebd0ed3dbe742d87d68fcefc8dc6dc35cb54390.tar.bz2
aports-1ebd0ed3dbe742d87d68fcefc8dc6dc35cb54390.tar.xz
testing/py3-pyzor: drop py2
Diffstat (limited to 'testing/py3-pyzor')
-rw-r--r--testing/py3-pyzor/APKBUILD38
1 files changed, 10 insertions, 28 deletions
diff --git a/testing/py3-pyzor/APKBUILD b/testing/py3-pyzor/APKBUILD
index a7310c81a4..55d50f9ad8 100644
--- a/testing/py3-pyzor/APKBUILD
+++ b/testing/py3-pyzor/APKBUILD
@@ -1,44 +1,26 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-pyzor
+pkgname=py3-pyzor
_pkgname=pyzor
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python implementation of a spam-blocking networked system that use spam signatures to identify them."
url="https://pypi.python.org/pypi/pyzor/"
arch="noarch"
-license="GPL-2.0"
-depends=""
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+license="GPL-2.0-only"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-pyzor" # Backwards compatibility
+provides="py-pyzor=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="e77b1cd0afd3884e6f2aa585cb423b46 pyzor-1.0.0.tar.gz"
-sha256sums="10ea114bdee2eee5edd6afe8eeddaaf605620445977ae019a3e9b1cbb6bc3b27 pyzor-1.0.0.tar.gz"
sha512sums="5ce22d23dac02f3b14b7e87f1049cdcd06b8b02a0214898bf9946d966e3d5e1e5788d82cdf7883641d0291dcf949483a926989482cdd344460d9f6a8e7182cc5 pyzor-1.0.0.tar.gz"