aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-qtpy
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 00:01:24 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-26 13:23:05 +0000
commit91f0070b940191ddf08eb94544b1696c7c48e850 (patch)
treefe82a2f3ac7cd6f1c216d08e8f093e6df5b0ad57 /testing/py3-qtpy
parentfad0db6d705ff17fa1b7152edbac7e46e57b5cbf (diff)
downloadaports-91f0070b940191ddf08eb94544b1696c7c48e850.tar.bz2
aports-91f0070b940191ddf08eb94544b1696c7c48e850.tar.xz
testing/py3-qtpy: modernize
Closes GH-8101
Diffstat (limited to 'testing/py3-qtpy')
-rw-r--r--testing/py3-qtpy/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/testing/py3-qtpy/APKBUILD b/testing/py3-qtpy/APKBUILD
index a672ffe1a8..53047bd1b2 100644
--- a/testing/py3-qtpy/APKBUILD
+++ b/testing/py3-qtpy/APKBUILD
@@ -8,24 +8,21 @@ url="https://github.com/spyder-ide/qtpy"
arch="noarch"
license="MIT"
depends="python3 py3-qt5"
-makedepends="python3-dev py3-qt5 py3-pytest"
+makedepends="py3-setuptools py3-pytest"
source="py3-qtpy-$pkgver.tar.gz::https://github.com/spyder-ide/qtpy/archive/v$pkgver.tar.gz"
builddir="$srcdir/qtpy-$pkgver"
# TODO: remove this once py3-qt5's a complete package.
options="!check"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}